Error in the LSMS Segmentation toolbox

Hi everyone,

When I use the tool “exact large-scale mean-shift segmentation, step 2.”

I get the following error:
2019-01-28 21:45:34 (INFO): Number of tiles: 6 x 6

2019-01-28 21:45:34 (INFO): Tile shifting ...

2019-01-28 21:45:34 (FATAL): itk::ERROR: GDALImageIO(0x7fcb978d4770): Attempt to create new tiff file `LSMSSegmentation_21e85708-fae7-4a92-be9e-lo_0_0_SEG.tif' failed: Permission denied

Same error occured for someone else a year ago,!searchin/otb-users/permission$20denied|sort:date/otb-users/b3bss2tqNg0/Db5fGv6LAwAJ. I have looked at the suggestions but nothing seems to work. My disk is not full and I have my working directory in good conditions.

Which system are you using ? Can you try using a different tmpdir using the tmpdir param ?

1 Like

I’m using a Macbook.
You’re a lifesaver, using the different tmpdir worked so perfect.

lifesaver, that’s all me :smile:

You can hit the like button so I can get plenty of discourse badges :wink: