imageClassifier error : GetBlockRef failed at X block offset ....., Y block offset .... what causes this and how to get rid of it?

No worries!
What do you mean “it doesn’t launch”?
gdalinfo is an executable that you need to run from the command prompt. You need to run gdalinfo my/path/to/image.tif and it should output infos about your image!

Oh ok sorry i’m not used to play with CMD, what should i change :
C:\Users\dmayerau>C:\Users\dmayerau\Desktop\OTB_teledetection\OTB-6.6.1-Win64\OTB-6.6.1-Win64\bin\gdalinfo Z:\zperso salariés\Benjamin_Stagiaire2019\beat_it\ROI_FINAL.tif
ERROR 6: Too many command options ‘salariÚs\Benjamin_Stagiaire2019\beat_it\ROI_FINAL.tif’
Usage: gdalinfo [–help-general] [-json] [-mm] [-stats] [-hist] [-nogcp] [-nomd]
[-norat] [-noct] [-nofl] [-checksum] [-proj4]
[-listmdd] [-mdd domain|all]*
[-sd subdataset] [-oo NAME=VALUE]* datasetname

Try this : C:\Users\dmayerau\Desktop\OTB_teledetection\OTB-6.6.1-Win64\OTB-6.6.1-Win64\bin\gdalinfo "Z:\zperso salariés\Benjamin_Stagiaire2019\beat_it\ROI_FINAL.tif"
As you have space in you path the executable is considering two arguments.

Ty a lot:
Driver: GTiff/GeoTIFF
Files: Z:\zperso salariÚs\Benjamin_Stagiaire2019\beat_it\ROI_FINAL.tif
Size is 28000, 38000
Warning 1: Cannot find pcs.csv
Warning 1: Cannot find datum.csv or gdal_datum.csv
Warning 1: Cannot find ellipsoid.csv
Warning 1: Cannot find prime_meridian.csv
Coordinate System is:
LOCAL_CS[“RGF93 / Lambert-93”,
SPHEROID[“unretrievable - using WGS84”,6378137,298.257223563],
Origin = (740000.000000000000000,6605000.000000000000000)
Pixel Size = (0.500000000000000,-0.500000000000000)
Image Structure Metadata:
Corner Coordinates:
Upper Left ( 740000.000, 6605000.000)
Lower Left ( 740000.000, 6586000.000)
Upper Right ( 754000.000, 6605000.000)
Lower Right ( 754000.000, 6586000.000)
Center ( 747000.000, 6595500.000)
Band 1 Block=28000x1 Type=Float32, ColorInterp=Gray
NoData Value=nan
Band 2 Block=28000x1 Type=Float32, ColorInterp=Undefined
NoData Value=nan
Band 3 Block=28000x1 Type=Float32, ColorInterp=Undefined
NoData Value=nan

Ok, there is nothing wrong on this side.

Can you tell us which OTB package you installed ?

I’m using OTB-6.6.1-Win64

Are you sure that your system is 64 bits ?
Can you try another package, like 6.6.0 or 6.4.0 ?

Yes i’m sure. Ok i will give it a try. Tomorrrow

Same error/problem with 6.6.0 :
Application.logger (FATAL) The following error occurred during OTB-application execution: c:\dashboard\otb\src\modules\io\iogdal\src\otbgdalimageio.cxx:435:
itk::ERROR: GDALImageIO(000001BB73EAE240): Error while reading image (GDAL format) ‘my\image’ : GetBlockRef failed at X block offset 0, Y block offset 4655

I just had the same problem using the ROI extractor with the same error message. I closed mapla and relaunched with the exact same settings and this time it worked. What is wrong with that image…

Anyone have an idea ?

I have no idea why you have this error…
One thing you can do though, as a workaround, is to use extractROI to cut you images in serval smaller one (10kx10k for instance) and then launch your trained classifier on it! Once you have all the classified images you can use the TileFusion to recover the initial big images…
Other than that I have no idea… Sorry…

Yes that’s what i have done tho, it took me two days but i have the image now. Could it be that my processor isn’t powerfull enough ?

Do the other OTB apps work fine? Can you try

otbcli_ComputeImagesStatistics -il "Z:\zperso salariés\Benjamin_Stagiaire2019\beat_it\ROI_FINAL.tif"


Yep it works great, i do it every time as my classifier (libvsm) requires stats. It takes a while but it worksstat_ROI FINAL.xml (433 Bytes)

If I understand correctly, the image you’ve linked to is one that works. Would it be possible to put somewhere the image that’s having issues and the data that’s required to run the application? We could then try to reproduce your issue.

If you would rather not upload the image, here’s another thing you can do:

otbcli_BandMath -exp 0 -out black.tif -il "Z:\zperso salariés\Benjamin_Stagiaire2019\beat_it\ROI_FINAL.tif"
otbcli_ConcatenateImages -il black.tif black.tif black.tif -out test.tif

Then try running the classification over test.tif. That will be a black image with the same number of bands (3), encoding (Float32) and projection as your original image. The classification won’t output anything useful, of course, but it might be interesting to see if it still crashes. here are some datas that failed on my pc, i’ll try your test as soon as possible.

And here the error that occured at 2% on the test image you asked me to create (same error again).
(FATAL): itk::ERROR: GDALImageIO(0000024F5BB008E0): Error while reading image (GDAL format) ‘Z:/zperso salari�s/Benjamin_Stagiaire2019/beat_it/test.tif’ : GetBlockRef failed at X block offset 0, Y block offset 882

Doesn’t the fact that it always crash at X block offset 0 mean something ?

Can you do

gdal_translate "Z:\zperso salariés\Benjamin_Stagiaire2019\beat_it\ROI_FINAL.tif" black.tif

What is the command-line that generated ROI_FINAL.tif ?

Can you try to generate this data on a different drive (usb key or usb drive) ?

i made a vrt of something like 25 tiles, saved this vrt as a tif file, extracted a tinier roi : “ROI_FINAL.tif” with “extract ROI” on otb from the .tif previous file.
i did your command what should i do next ?
i tried on another computer and i had the same problem