Missing output model file


Retrieve saved but missing output model file

Configuration setup

My system: Windows10
Version of the OTB: 8.0?

Description of my issue

Hello everyone. I am creating a training model file using the TrainVectorClassifier tool in QGIS 3.16. Everything appears to okay as the results indicate that the execution is completed. I however cannot find the saved files (output model and confusion matrix files) in the designated folder (even tried several folders). I also tried saving them as temporary files, and yet I still do not find them. I thought these files were somehow deleted by my antimalware software but I found out it didn’t after I disabled the software and tried the process again. Please can someone help me out as this appears strange to me? Thanks a lot!:


this is weird, in particular because the model file should be written before computing the confusion matrix. So the program should crash before the end if there was an error when writing this file. Can you provide the full log of the application ?

Can you try to launch the application using the “mapla (.bat?)” program at the root of your OTB installation ?


Hello Cedric,
Sorry I mistaken the OTB version. It is version 7.2.0 and not version 8.
Moreover, I am using the OTB application within the QGIS interface.
In the TrainVectorClassifier tool, there is an option where the output model and the confusion matrix can be saved at the same time after the training process (which also appears strange to me).
I am attaching the full log (find below) with the hope it provides adequate information.
Moreover, I actually do not know how to launch the OTB application using the mapla.bat file. Thank you.

Algorithm ‘TrainVectorClassifier’ starting…
Input parameters:
{ ‘io.vd’ : [‘H:/QGIS/joined.shp’,‘H:/QGIS/unjoined.shp’], ‘io.stats’ : ‘’, ‘io.out’ : ‘H:/QGIS/outputmodel.txt’, ‘io.confmatout’ : ‘H:/QGIS/confusionmatrix.csv’, ‘layer’ : 0, ‘feat’ : ‘“meanB0 meanB1 meanB2 varB0 varB1 varB2”’, ‘valid.vd’ : None, ‘valid.layer’ : 0, ‘cfield’ : ‘“label”’, ‘v’ : True, ‘classifier’ : ‘libsvm’, ‘classifier.libsvm.k’ : ‘linear’, ‘classifier.libsvm.m’ : ‘csvc’, ‘classifier.libsvm.c’ : 1, ‘classifier.libsvm.nu’ : 0.5, ‘classifier.libsvm.opt’ : True, ‘classifier.libsvm.prob’ : False, ‘rand’ : 0 }

Execution completed in 186.55 seconds
{‘io.confmatout’: ‘H:/QGIS/confusionmatrix.csv’,
‘io.out’: ‘H:/QGIS/outputmodel.txt’}

Loading resulting layers
Algorithm ‘TrainVectorClassifier’ finished