About S1 Tiling installation


I try to install S1 Tiling 0.3.0 but I still have this error message. I work on Fedora, with OTB 7.4.0, Python 3.7.6 and GDAL 3.0.4 .

What’s my error and what can I do ?

Thanks in advance.


The message is definitively strange as it seems to refer to the same version of gdal.

Anyway, you should avoid having both versions of S1Tiling in the same environment. Either do a upgrade of S1Tiling with pip (I guess it should work), or simply start over with a fresh and empty environment.

Note: a docker is also available.

Oh. I’ve missed an important information: in case you’re using OTB binaries, you will have to use the version of GDAL that is shipped with OTB and no other one when executing OTB applications (which S1Tiling does).

Normally this should be taken care of automatically if you follow the procedure(s) described in S1TIling documentation: Installation — S1Tiling 0.3.0 documentation

Thank you for your answer.
I’ll try to create a new environment.

For OTB binaries, how can I know which GDAL versions is necessary ?

That will be taken care of automagically by the gdal-config patched script we provide with S1Tiling. Installation — S1Tiling 0.3.0 documentation § OTB&GDAL

I created a new environment with python 3.7.6 and OTB 7.4.0. I patched files as explain in documentation, but I still have the same error message.

I tried to install gdal 3.2.2 with command line : conda install gdal==3.2.2 and I have this error message. If I understand, there are conflicts regarding the “glibc” version ?

gdal is already installed with OTB 7.4. binaries. The only missing thing is the Python bindings. pip install s1Tiling will take care of it (as long as 1. you’ve dropped gdal-config in the right bin/ directory, and 2. updated LD_LIBRARY_PATH in the otbenv script as explained).

Don’t add anything that isn’t in the installation procedure(S – choose the one fitting your environment).


Thanks for your answer.
I tried again to install S1 Tiling in a new environment and I think my problem comes from the OTB installation.
Here the message I have when I install it. What do you think about it ? Is it normal ?


the Python bindings shipped with the binary packages are compiled for a specific Python version (3.5). To use it in your environment, you can recompile it by doing the following:

cd /home/scp/OTB-7.4.0-Linux64/
source otbenv.profile
ctest -S share/otb/swig/build_wrapping.cmake -VV

you might need to install cmake to run these commands


Hi Cedric,

I installed cmake et run your command. I get this …
What can I understand ?

Thanks in advance.

You need to install a C++ compiler.

IIRC, the packet name on ubuntu will be “g++”

1 Like

I ran “sudo dnf install gcc-c++” and tried again the last command. I get this error message…

Did I forget something ??

Thanks for your help!

A few other development oriented packages are required to update OTB Python binding.

You could find the minimal required list in the Dockefile used to prepare S1Tiling environment here: ubuntu/base/Dockerfile · master · s1-tiling / s1tiling-dockers · GitLab

(You’ll also see the list of other commands that needs to be executed in in which order (up-to S1Tiling installation excluded) on minimal ubuntu systems. Note: only the apt commands needs to be executed as root with sudo) (EDIT: and of course if you want to use Python 3.7, use Python 3.7 instead of 3.6)

Thank you very much for your help! I will try to install all the required packages.