Can't save data with Monteverdi

#1

Hello,

How can I solve this problem?
ERROR: itk::ERROR: GDALImageIO(05BC66A8): GDAL Writing failed : Impossible to create the image file name ‘c:/Program Files/2013_DFTC/kmeans.tif’ : Attempt to create new tiff file `c:/Program Files/2013_DFTC/kmeans.tif’
failed in XTIFFOpen().

Thank you.

0 Likes

#2

Hi milou7,
What are you trying to do and what is the input file? It’s hard to tell without context what’s going on here.

0 Likes

#3

Hello,

I am using Monteverdi on Virtual Machine on a MacBook Air, I am trying to save a result of a KMeans classification.
Thank you for help.

0 Likes

#4

Does it happen if you try to save to another location than c:/Program Files/2013_DFTC? You might not have write permission.

0 Likes

#5

yes I try to save in the desktop, but I steel have the same error !

0 Likes

#6

What version of OTB are you using and how did you install it?

0 Likes

#7

I have this version : OTB-6.6.1-Win32

0 Likes

#8

Hmm it’s hard to debug without more information. Did you try with another input image? Do you have enough storage space for the output? Are you able to use other OTB applications correctly?

0 Likes

#9

Is it normal that it is c:/Program Files.... instead of C:/Program_Files? (small c instead of big C)

0 Likes

#10

Hello,

A priori, Windows filesystem is not case sensitive. So, there should be no difference between ‘Program Files’ and ‘program files’.

@milou7 You are trying to write in the ‘*C:\Program Files*’ directory, which is a MS Windows protected system directory, under a virtual machine. This should translate to : trying to write into the .ISO image of the virtual machine which should be read-only.

You tried to write in the “Desktop” directory your user account which might also be read-only under your virtual machine. Could you please check the permissions of that directory?

Often, virtual machines mount your laptop hard-drive as a shared drive under the Windows virtual environment. Could you please try to locate this drive and try to save on it?

0 Likes