DimensionalityReduction Memory/Tiling

Windows 10 pro
orfeo 8.0.1

I notice that when I run DimensionalityReduction, (ICA), the ‘ram’ option isnt respected, and reverts to the default 256mb. The large raster is then tiled internally for processing. Is this dependent on formats involved, options chosen for the run, or something else I’m missing ie in what situations is the defined ‘ram’ option actually used? I’m using a workstation with a lot of ram (512 gb) and would like to take advantage of it where possible.

Thank You!


This might be a bug in the implementation of the ICA in OTB. The parameter might not be connected to the ICA filter.

Can you try setting the OTB_MAX_RAM_HINT environment variable (in MB) before running the application ?


1 Like

Thanks for your response. I’m not sure how to set that variable? I’ve set the ‘ram’ variable from commandline. I havent been running this in python, perhaps you need to do it there?