Does OTB works in ubuntu 22?

Hello, recently i upgrade my laptop UBUNTU 22, but when i tried to install OTB i couldn’t find it, I also tried to add repository its not successful either, is there anyone who face the problem, any solutions? thank you!

Dear @ermyas,

Thank you for using OTB.

Ubuntu 22.04 was released yesterday, and we didn’t try it yet. Did you try to install OTB following this procedure ?

Best regards.
Julien :slight_smile:

Hi @ermyas

We tried to compile OTB 8.0 in ubuntu 22.04 but there are some superbuild dependencies that needs to be upgraded, because gcc 11 added some mandatory includes that are not in the current version of these dependencies (Qt 5.15, HDF4 and Boost). We will let you know when this upgrade will be done.
We tested with HDF4 4.2.15 and Boost 1.75 which resolves the problem for these two dependencies. For Qt5 , you have to patch it : Fix build with GCC 11: include <limits> (8252ef5f) · Commits · Qt Project / qt / qtbase · GitLab

In the mean time, you can use the docker image based on ubuntu 20.04 :
docker pull orfeotoolbox/otb:8.0.1

Best Regards

1 Like

Thank you for your reply, if you have seminars, trainings we are also interested to attend.