Error while using S1 Tiling docker

According to the document at Usage — S1Tiling 0.3.2 documentation I tried to run S1 Tiling docker as below:
docker run -v /mnt:/MNT -v “$(pwd)”:/data -v $HOME/.config/eodag:/eo_config --rm -it /data/Main_work/cloud_removing/S1Processor.cfg

the last item is the directory where I have put the sample “.cfg” file downloaded from this link “Usage — S1Tiling 0.3.2 documentation”.
But after running, this error encountered:
“CRITICAL - ERROR: tmpdir=/datalocal2/share2/tmp is not a valid path”

I tried to change the “tmpdir” to some other directories but did not work. By downloading the “.cfg” file you can see these lines:

# Path to a temporary file
tmp : /datalocal2/share2/tmp
# tmp : %(TMPDIR)s/s1tiling
My operating system is “Ubuntu 20.04.4 LTS” and running S1 Tilling 0.3.2-ubuntu-otb7.4.0 docker version.
As I am new to S1 Tiling, I do not know where the problem is, so I would appreciate any help. My general purpose is to download some sentinel1 images and then let S1 Tiling to process them and I will do some future processes on the outputs.


The directory shall be a directory that will exist as seen from the docker perspective (not from your machine perspective).

If you mount your current running directory as “/data”, then in the docker it’ll be seen as “/data”. There is no “/datalocal2” from the docker perspective. Am I clear enough?

Thanks for your reply. If I understand well, instead of using “/datalocal2”, I should give the point where the container is mounted to the local machine which is “/data” here.
Best wishes