LSMS Segmentation won't run in QGIS 3.6.3

“ERROR 4: Attent to create new tiff file ‘OTB_SegVector_test_0_0_SEG.tif’ failed: permission denied”

screen-cap of log follows:

I am running from an admin profile and have tried different paths and filenames. Using default settings for the tool.

QGIS 3.6.3
OTB 6.6.1

FWIW…the tool runs from standalone OTB (launched via mapla.bat). [

Cheers,
Will

Hi,
First guess is that the application LargeScaleMeanShift doesn’t use the tmpdir parameter used in internal app Segmentation. There may be something to fix in this application. By default the temporary file OTB_SegVector_test_0_0_SEG.tif is a relative path.

Can you launch QGis from cmd, in a directory where you have write access, and try again?

I launched QGIS.bat from cmd successfully. However, I get the same error.

I am logged-in as an admin and am able to write/edit/delete within the folder I selected. For example, in the QGIS browser, I can navigate to the folder, right-click > new > shapefile. I can add the new shapefile, toggle editing, add features, and save successfully.

I can also write other outputs from OTB processes (e.g. “Edge Extraction”) to the same folder.

Cheers

When testing the “Edge Extraction” application, did you set a relative output path as well ?