Mode.raster.out error - LSMS on QGIS

#1

Hi, Im new to OTB (took me a few days to get the QGIS plugin working) and im trying to run the LargeSegmentMeanShift tool to segment a color-NIR image using the QGIS plugin. Ive left the settings to default and when i set the output mode to vector i get the error:

“Incorrect parameter value for mode.raster.out”

When i set the output mode to raster i get the opposite error:

“Incorrect parameter value for mode.vector.out”

See below

I installed OTB from the linux .run file (https://www.orfeo-toolbox.org/download/) and the QGIS plugin from the git repo (https://github.com/orfeotoolbox/qgis-otb-plugin). This is brand new laptop, Im running Ubuntu 18.10 (Pop!_OS actually). - go easy, im new to linux OS.

QGIS 3.4.4 installed from gnome apt

2 Likes

#2

Hi,

Thanks for reporting. I think this issue is already filed as a bug in our gitlab, and we are working on a fix:

Problem is that OTB has an elaborated parameters dependency mechanism that does not translate well in QGis processing framework :vector.out and raster.out are both mandatory in OTB parameters model, but OTB knows that vector.out is a sub-parameter of vector choice (resp. raster.out from raster choice) and thus only require them when the corresponding choice is selected.

In Qgis, this translates as both parameters being mandatory, hence your error.

I think you can work-around this by setting a dummy value for the missing parameter, for instance set vector.out to not_used.gpkg when in raster mode and raster.out to not_used.tif when in vector mode. Let me know if that works for you. Hopefully we will soon have a fix.

0 Likes

#3

Hi @jmichel

I am having the exact same error on a Windows install, and the workaround is not working for me.

Any ideas for another workaround?

Thanks!

0 Likes

#4

image

0 Likes

#5

Hi,
There is a new version of the plugin that you can try.


This should solve your problem! Any feedback on this can be directly done on this issue!
Antoine

0 Likes