OTB atmospheric corrections crash

To anyone may help me,
I’ve just downloaded and installed for the first time OTB, on windows10, and I’trying to use it to perform atmospheric corrections on supported data by its graphical interface (launched by mapla.bat).
The GUI works properly,
I’ve activated the OpticalCalibration GUI and launched atmospheric corrections by selecting “Image to Top of Canopy reflectance” and all relative parameters (the most ones automatically filled by OTB when loading the input image) for some different data types (SPOT6 and 7, WV2 and Pleiades, all data freely available on the web).
For all data the behavior is always the same, the GUI crashes immediately without generating any output and giving no messages.
I also tried different combination of the parameters values and installed the Visual C++ version suggested by the web site, but the the GUI still crashes.
I’ve also tried to generate TOA reflectance before (by setting “Image to Top Of Atmosphere reflectance” menu), and it works properly and generates the relative tiff file.
Anywaym when I put them as input to generate TOC reflectance, also in this case, the GUI crashes.

Any idea on what could be wrong?
Any test to perform to understand the problem?

Thank you in advance


Can you try with QGIS by including the OTB applications and launch your treatment to see if it also crashes? It may be related to some OpenGL glitches with windows, on some machines with intel graphics it could happen. If it is the case, I may have a solution also, but try before with QGis. If you prefer, you can try with the command line interface

Best regards

Thank you Romain,
I’ll try by using QGIS and I’ll let you know the results.


At the end I solved the problem by launching the atmospheric correction tool via command line, and it works both under windows and under linux (on docker).
Thank you for the support.