OTB in QGIS : proj.db file cannot be found

Hello everyone !

I have a trouble using OTB in QGIS. I want to despeckle a Sentinel-1 image coming from copernicus sci-hub. I’ve followed the guidelines provided to install the OTB in QGIS, but when I try to run the despeckle noise tool, I get an error saying ERROR 1: PROJ: proj_create_from_database: Open of C:\Users\Clément\Desktop\OTB\share\proj\proj.db failed

I have read in certain forums that I should set the PROJ_LIB environement. I have done it through the Python command prompt integrated in QGIS using this command : import os and then
os.environ[‘PROJ_LIB’] = 'C:\Users\Clément\Desktop\OTB\share\proj’
It still doesn’t work and the error is the same.
I have the latest version of QGIS (3.22) and I installed OTB recently so I don’t think it could be a problem of version.

Can anyone help me about this ?
Thanks in advance

Dear @clem_jbt,

Thank you for using OTB !

I suspect that the problem comes from the accentuated character in the path of your image. Could you try to move your image to an other directory ?

Hi @clem_jbt

On Windows, there are known troubles with accented letters in the path, Could you install OTB on another location, where there is no accented characters and try again, as suggested by Julien ?

Hello ! Thanks for your answers !

Indeed I installed OTB in a “safer” path (C:\OSGeo4W\apps\OTB-7.4.0-Win64) but it still doesn’t work. The new error message is the following : ERROR 1: PROJ: proj_create_from_database: ellipsoid not found
It seems that the geocoding is the problem. However, I checked and the geocoding should be included in the TIFF file. I download them directly from the Coperniicus scihub so there should not be any problem regarding that. I also tried to apply the function via mapla or even with S1tiling (but I have other problems trying to make this one run…) or SCP but it doesn’t work either (I let SCP preprocessing tool run for 15 hours for only one image and it didn’t even reach 1%)
I tried to force the geocoding by applying a projection with GDAL but that doesn’t work either.

ERROR 1: PROJ: proj_create_from_database: ellipsoid not found

This is a known issue in GDAL 3.2.2, which is used by OTB. This happens for Sentinel1 products. This error doesn’t seems to alter OTB’s results. Did you check your outputs?