OTB on Mac Qgis

Hello everyone,
I installed OTB on my mac as well as on qgis. But I have a problem when I run an OTB program it doesn’t work. I have this error message every time:

Thank you !


Which versions of QGIS and MacOS are you using ? I have no problem running OTB 7.2 in QGIS 3.14 on Mojave. Actually, I think your problem is related to your otb installation, not to the QGIS plugin.

Have you moved the OTB installation dir (for example by copying it in /Applications/OTB-7.2.0) ? This would explain the error.

In a terminal, can you run :

otool -l /Applications/OTB-7.2.0-Darwin64/bin/otbApplicationLauncherCommandLine

and look at the LC_RPATH value (probably the last value printed). This path should contain the OTB libraries (e.g. libOTBCommandLine-7.2.1.dylib), in your case otool should return something like

Load command 35
          cmd LC_RPATH
      cmdsize 40
         path /Applications/OTB-7.2.0-Darwin64/lib (offset 12)

but I suspect it is not the case.


Thank you for your response,

I use Qgis 3.10 and macOS Catalina version 10.15.6.
Yes it’s a copyright…
When I run in terminal : otool -l /Applications/OTB-7.2.0-Darwin64/bin/otbApplicationLauncherCommandLine
I have this :

A space is missing in your command after -l, you wrote:

otool -l/Applications/OTB-7.2.0-Darwin64/bin/otbApplicationLauncherCommandLine

You should not move the OTB installation directory after its extraction, because the rpath is hardcoded in the executables. If you want to install otb in /Applications, you should use the target option when extracting the archive:

chmod +x ./OTB-7.2.0-Darwin64.run
./OTB-7.2.0-Darwin64.run --target /Applications/OTB-7.2.0-Darwin64