OTB segmentation not working properly

Context

I am trying to do object based Land cover classification for that whenever I run the segmentation process even with different parameters the results is just a single polygon which is very strange.

Configuration setup

My system: Windows10, core i7
Version of the OTB:latest version available at website I guess 7.3
I installed the OTB with: the binaries, the Debian package management, the SuperBuild, other?

If relevant, you may also provide:
QGIS version: 3.18?
Python version: * 3.8?*

Description of my issue

I tried running the standalone mapla as well as the QGIS OTB plugin but the problem is there is no error but the result is very strange even when I use train image classifier with my training sights it takes so long around 2 hours but the result is just a blank no data tif image. I am using a sentinel 2 layer stack with 11,8,4,3,2 bands for classification.
Input parameters


The result is a single polygon covering whole image
Kindly help me in this regard as this is final semester project and I am running on time.
looking forward

Dear @HiraZafar,
Thank you for using OTB.

Did you try various values for the parameters? I don’t know the dynamic of your input image, but a range radius of 600 seems huge. For instance, in our examples, it is set to 80 for a quickbird image.

I hope it helps.
Julien.

yes I did tried it by giving very small range radius as well than i get a single polygon on the image.

@HiraZafar what is the dynamic of your input image ? If the values of your input image lie between 0 and 1 a range radius of 10 is still too much.

To reduce processing time you can try reducing the values of the Spatial radius and the minimum region size.

Cédric