OTB toolbox missing after QGIS restart

I installed OTB 6.6.1 yesterday with QGIS 3.8 and the tools were in the toolbox. I ran a tool and it worked. I was happy. I installed it using this youtube video as a guide because I couldn’t figure out how to install OTB without it: https://www.youtube.com/watch?v=Jl_G1XIblJs

I then closed QGIS. I then reopened the same QGIS project but now I cannot see the OTB tools in the toolbox. I have completely removed OTB from its C:/ drive installation location and reinstalled it and restarted the plugin. Nothing works. The plugin is still listed but the OTB tools are not in the toolbox. Where have they gone?

Please can you guide me.


I am experiencing the same issue.

However, when the plugin is deactivated, OTB reappears in the Processing Toolbox (only the icon is missing). And it functions!

1 Like

The plugin is in QGIS by default now (see QGIS 3.8 release notes). So to use OTB in QGIS you should only have to configure OTB in Settings/Options/processing (I had to remove my local qgis-plugin from QGIS to make it work).


Thank you K and C.

I now have the OTB toolbox.

I had originally installed OTB to my C: drive but I have now removed it from the C: drive. At a different time (and currently) it is in my ‘software’ folder (see below image) and it still points to the location on my D: drive. But it works!


I had originally followed this guide but it did not work - the toolbox kept disappearing upon restart of QGIS even though the plugin was installed: https://gitlab.orfeo-toolbox.org/orfeotoolbox/qgis-otb-plugin/blob/master/README.md

Thank you both for your combined help and comments. Excellent!