QGIS 3.10 LTR plugin installation problems

Installation of the OTB with the new LTR is bugged (I think). The plugin appears in the core list, but QGIS reports it as broken with missing metadata. It can’t be installed and the next steps of adding the folders in the providers section does not follow.

Is the ‘installation’ of the OTB merely a matter of unzipping the package? ~Is this behaviour normal?

QGIS LTR installed with the standalone installer in Win64.

As a workaround I have just downgraded my QGIS to 3.4.15 and tried the older method of installation based on this: https://gitlab.orfeo-toolbox.org/orfeotoolbox/qgis-otb-plugin

That worked, but I had to add a \ at the end of the folder names. 3.4 is a very good version with no bugs with GRASS and now OTB functions. Seems like the optimal solution for QGIS integration at the moment.

Which version of QGIS 3.10 are you using ?

I just tried with the 3.10.3-3 win64 installer and had no problem with the plugin.

Note that in 3.10 the plugin should not be installed with the plugin manager (and should not appear in the list), as it already is in the core of qgis (I don’t think that is what you tried you do, but just to be sure).


I was using the LTR of 3.10. Must have gotten it wrong.

But 3.4.15 has other advantages because GRASS and SAGA work fine whereas there are know issues in later versions. I know ORFEO will pretty much do everything (and it’s so much faster!) , but I like to use some GRASS and SAGA tools in my teaching.