SARCalibration & OrthoRectification output blank

Hi all! :slight_smile:

I have pulled a Docker image of Orfeo7.2.0 from TerraDue and I have tried to process a few Sentinel-1 GRD images.

I ran the otbcli_SARCalibration cmd line on VV-band tiff kept inside the “.SAFE/measurement/” folder.

It ran and completed.

It gives an output of “.tif” and “.geom” files.

When I open the .tif in QGIS, it was not georeferenced.

So I went back to otbcli and did a “otbcli_OrthoRectification” as below -

otbcli_OrthoRectification vh20141027-cal.tif -io.out vh20141027-cal_rect.tif -map wgs -opt.gridspacing 5 -interpolator nn

Without grid spacing being set it consumes more and more memory and crashes. With -opt.gridspacing set to half of GRD pixel ground sampling range, it works well.

Now the output .tif file is georeferenced.

But opening the output in QGIS gives a blank image. NOT BLACK, just blank.

I think i missed something, please do give your feedback, thanks!

Configuration setup

Version of the OTB: 7.2.0
I installed the OTB with: terradue/otb-7.2.0 from DockerHub

Hey guys. It was a mistake on my part.

Here is how it turned out to be ok. Initially i thought I will have the results in WGS projection, but then I decided to go the UTM way next time for Orthorectification.

So I got the UTM zone that my coordinates fall in , and ran the following command. It worked.

the UTM zone can be found in many ways, including otbcli_ObtainUTMZoneFromGeoPoints

otbcli_OrthoRectification vh20141027-cal.tif -io.out vh20141027-cal_rect.tif -map.utm.northhem true -map.epsg.code 32614 -outputs.spacingx - 10.0 -outputs.spacingy -10.0 -interpolator nn -opt.gridpspacing 40.0 -opt.ram 512

This was for Sentinel-1 GRD data.

Hope this is helpful for any rookies out there.

1 Like

Thank you for your feedback!

1 Like