Setting up OTB in QGIS (tools not showing)

#1

Hello all,

I am having trouble getting the OTB processing Tools to show up in QGIS. My goal is just to have them show up to use in the QGIS interface.

Versions I am using are:
QGIS - 3.45 Madeiria (long term release) 32 bit
OTB- 6.6.1 (12-12-18)
Processing OTB Provider (Plug in)- 1.4.2 INSTALLED IN QGIS PLUGIN

This is how I have the OTB file set up in my folder:
C:\OTB

This is how I have the plug in download in my folder: (Do I even need this?)
C:\qgis-plugins\qgis-otb-plugin

These are the Processing Options I have input in QGIS:

OTB application Folder: C:/OTB/lib/otb/applications
OTB Folder: C:/OTB

This is the only Processing Tool showing up under OTB: (This is what I am trying to fix)

I have already gone through many many many forum pages, download links, and OTB pdfs and cookbooks. Many are outdated or simply just didn’t work (or at least I couldnt get them to work).

Please do not just send me a link without a detailed description of what I need to update on my configuration of the processing options or downloads, etc. There is a very high possibility I have already looked at that and tried that method so please explain how I did it wrong.

Thank you in advance for your help, I appreciate any time taken to help me out.

0 Likes

#2

Hi,
I encounter this kind of behavior when the OTB platform does not match the user platform. You are using OTB for Windows 32bits? Is your Windows arch is 32?
If all of this is ok, you can have a look at the folder C:/OTB/lib/otb/applications to check that you have other DLL files (representing other OTB applications). You can also have a look at C:/OTB/share/otb/description to see if you have text file (again representing OTB applications).
I hope it helps.
Antoine

0 Likes

#3

Hello Antoine,
This fixed it! thank you for reply it saved me alot of troubles.
I downloaded the 64 bit and it worked perfectly.
Thanks again.

0 Likes