Tensorflow version inside the Docker Image

I’m using otbtf for a project where I ran different models on Tiff files and deployed an application built using Streamlit on GCP to run these models. I’m using the otbtf as base image in my Dockerfile which is what I need but the issue is for one of my models where I need the Tensorflow 2.15.0 version but the base image comes with 2.14.0 version. I tried to install the required Tensorflow version by adding on the requirements.txt file. I have successfully created a Dockerfile and deployed it. But still it is using 2.14.0 version instead of 2.15.0 even though I installed it.

Kindly share if there is any other way that I can use the latest tensorflow version by updating the current version to a newer one.

Hi @zeros_ones , we are not the maintainers of OTB-TensorFlow and not even users of this soft, only maintainers of OTB.
I don’t know how the TensorFlow installation is done in their docker. Nevertheless I advice you to take a look at otbtf/Dockerfile at develop · remicres/otbtf · GitHub and follow this issue on their github Support for TF 2.16.0 · Issue #97 · remicres/otbtf · GitHub . You can also post an issue on their bug tracking. They will better know how their soft work!
Hope that it helps you and sorry to not come with a real solution