TrainImagesClassifier not producing output files


Hey guys, I am trying to perform image classification on satellite images as part of a larger project. I am a new user of this toolbox, so I am unsure if this is just user error or another problem. I tried looking for similar solutions, but I could not figure out what the problem is.

Configuration setup

My system: Windows11
Version of the OTB: 8.1.1
I installed the OTB with: the standalone windows package

QGIS version: 3.28.4
Python version: 3.9.5

Description of my issue

I am running the TrainImagesClassifier tool in QGIS, the program seems to work fine, and no error messages are displayed. However, when viewing the folder location, I cannot find the saved output model or confusion matrix files. I tried saving them to a different folder and as temporary files, however, they are still not being produced. Below I attached the log where I attempted to save the model output file. I would greatly appreciate any help on this, thanks!

QGIS version: 3.28.4-Firenze
QGIS code revision: fd0fb72ab3
Qt version: 5.15.3
Python version: 3.9.5
GDAL version: 3.6.2
GEOS version: 3.11.1-CAPI-1.17.1
PROJ version: Rel. 9.1.1, December 1st, 2022
PDAL version: 2.4.3 (git-version: f8d673)
Algorithm started at: 2023-03-13T10:41:28
Algorithm 'TrainImagesClassifier' starting…
Input parameters:
{ '' : ['SENTINEL2_L2A:/vsizip/C:/Users/altus/Downloads/'], 'io.vd' : ['C:/Users/altus/Documents/roi1.shp'], 'io.valid' : None, 'io.imstat' : 'C:\\Masters\\Satellite_Images\\test.xml', 'io.out' : 'C:/Masters/Satellite_Images/model_output.txt', 'io.confmatout' : 'TEMPORARY_OUTPUT', 'cleanup' : True, '' : 1000, '' : 1000, '' : 1, 'sample.vtr' : 0.5, 'sample.vfn' : 'class', 'elev.dem' : '', 'elev.geoid' : '', 'elev.default' : 0, 'classifier' : 'libsvm', 'classifier.libsvm.k' : 'linear', 'classifier.libsvm.m' : 'csvc', 'classifier.libsvm.c' : 1, 'classifier.libsvm.gamma' : 1, 'classifier.libsvm.coef0' : 0, '' : 3, '' : 0.5, 'classifier.libsvm.opt' : False, 'classifier.libsvm.prob' : False, 'rand' : 0 }

Execution completed in 23.15 seconds
{'io.confmatout': 'C:/Users/altus/AppData/Local/Temp/processing_TpscOY/aa9c496bd3f045e288e35d9369f3f5ac/io_confmatout.file',
'io.out': 'C:/Masters/Satellite_Images/model_output.txt'}

Loading resulting layers
Algorithm 'TrainImagesClassifier' finished

The output directory you set is wrong? 'SENTINEL2_L2A:/vsizip/C:/
P.S. due to your security, I recommend you to not write full paths of your system on the internet :slight_smile:

That was set by QGIS, weird, but thanks :grinning: