Trouble with no data in otbcli_ConcatenateImages -32768 & 2.29480686311718815e-316

Hi,

I am trying to concatenate a Pléiades multispectral image (4 band) with the NDVI I just calculated with otbcli_RadiometricIndices. It worked many times on other Pléiades MS image…until I run into an unexpected behavior today.

gdalinfo on both images shows that the nodata is -32768 but during concatenation, the output no-data is set to 2.29480686311718815e-316
I extracted a part of the image with only no-data in it but the same occur with the full image.

otbcli_ConcatenateImages -il  ExtractROI.tif RadInd.tif -out outIm.tif
2022-01-11 18:51:03 (INFO) ConcatenateImages: Default RAM limit for OTB is 256 MB
2022-01-11 18:51:03 (INFO) ConcatenateImages: GDAL maximum cache size is 6397 MB
2022-01-11 18:51:03 (INFO) ConcatenateImages: OTB will use at most 24 threads
2022-01-11 18:51:03 (INFO): Estimated memory for full processing: 1.52588MB (avail.: 256 MB), optimal image partitioning: 1 blocks
2022-01-11 18:51:03 (INFO): File outIm.tif will be written in 1 blocks of 150x150 pixels
Writing outIm.tif...: 100% [**************************************************]Warning 1: outIm.tif, band 5: Setting nodata to 2.29480686311718815e-316 on band 5, but band 1 has nodata at -32768. The TIFFTAG_GDAL_NODATA only support one value per dataset. This value of 2.29480686311718815e-316 will be used for all bands on re-opening

Thanks for any help!

César Deschamps-Berger
RadInd.tif (29.9 KB)
ExtractROI.tif (117.9 KB)

Dear @cesardb,
Thank you for using OTB.

I tried the ConcatenateImages with the two images you provided, and I see no problem with the NoData. Here is what gdalinfo says:

Band 1 Block=150x2 Type=Float32, ColorInterp=Gray
  NoData Value=-32768
Band 2 Block=150x2 Type=Float32, ColorInterp=Undefined
  NoData Value=-32768
Band 3 Block=150x2 Type=Float32, ColorInterp=Undefined
  NoData Value=-32768
Band 4 Block=150x2 Type=Float32, ColorInterp=Undefined
  NoData Value=-32768
Band 5 Block=150x2 Type=Float32, ColorInterp=Undefined
  NoData Value=-32768

I used OTB version 7.4. Is it the same for you?

Sincerely.
Julien.

Thanks for your answer.
I was using OTB 7.0 the one by default on my work server.
I found the bug up to OTB 7.2.
It disapears in OTB 7.3…
Then I guess I should simply use a more recent version. :slight_smile:

Thanks and best regards

César

1 Like