Worldview2 Optical Calibration BandID error

Hi OTB community!

I am trying to use the OTB Optical Calibration tool to atmospherically correct Worldview2 Level 1b imagery. I set up OTB version 7.2.0 on a Windows 10 from the standalone binary download. I’ve tried to run the tool through Monteverdi, the command line, and through the QGIS toolbox. However, every time I run the tool I receive the following error:

(FATAL) OpticalCalibration: itk::ERROR: WorldView2ImageMetadataInterface(000002ACCB400970): Invalid bandID Unknown

I’ve tested different combinations of files in the input image folder but they all create the same error. The associated image files I have are: .tif, .imd, .xml, .geo, .rpb, .eph, .att, .til.

I noticed an older discussion topic where the issue came from having “ms1” instead of “multi” as the image type so I went through to check all the header files and checked that they all are listed as “multi.”

Any help or recommendations would be useful!



looking at the code, it seems that the Worldview metadata interface only accepts "Multi" (with a capital M), "MS1" or "P" as bandId. However in your case the bandId has been parsed as "Unknown", so I the field can’t even be found.

Maybe the problem comes from the files extension associated with the image files ? OTB relies on OSSIM to read Worldview metadata, which tries to open the ".IMD", ".ATT", ".EPH" (etc) files associated with the tif product, but it looks like you have ".imd", ".att", ".eph" (etc) instead.


Hi Cédric,

Thanks for your response. Sorry for the confusion, the bandID is actually “Multi” and the file extensions are all capitalized so I would think that OTB should be able to parse them.