OTB TrainVectorClassifier

The OTB was recently updated to 7.0. “User definied input centroids” has been added.

Can you explain how to process the data?

Hello,

I’m assuming you are using OTB through QGIS, as I can only reproduce your produce using the QGIS plugin.

I think this is a bug, this parameter should only be available when using the kmeans algorithm (the result of this algorithm are dependent on the initial centroids) and should not be mandatory anyway. I will make a fix in OTB. In the meantime you have two workaround :

  1. Set a value to the “User definied input centroids” (any string will work). The application should start correctly, and the parameter will be ignored, you should have the following log :
WARNING: Parameter -classifier.sharkkm.centroids.in will be ignored because -classifier is libsvm.
  1. Use another wrapper (monteverdi, command line, python …). I think this bug only applies on the QGIS plugin.

Hope that helps,
Cédric